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Preface:
Early in 2004, Royce Bell, KX7Q, floated the idea of writing a comprehensive manual for Amateur Contact Log on the N3FJP_Software_Users e-mail reflector, but he threw in a twist.  Instead of Kimberly and me creating the manual, Royce suggested that the bulk of the writing should be done by Amateur Contact Log users.  Before we knew it, Royce had set up an e-mail reflector for this project, and 37 hams joined the group!
I can’t thank everyone enough who participated in this project.  There was input from many, and I appreciate all your contributions very much.  I’d like to offer a special word of thanks to Royce Bell, KX7Q, for putting the project in gear, Ed Leicester, KG4QMI, who went far beyond the call in writing, and Kimberly, KA3SEQ, who helped edit and fit all the pieces together. You all did an outstanding job, and I can’t thank you enough.
If you are just getting familiar with Amateur Contact Log, I know that you’ll find this resource very valuable, but don’t start here.  First enter a couple of contacts and try some of the settings to see what happens.  I think that you will find Amateur Contact Log very intuitive, and the best way to learn is by experience.
What follows is The Definitive Guide to Amateur Contact Log.  We hope this information will add to your enjoyment of using the software.  As you use the guide, if you find areas requiring additional explanation, you have an idea for a sidebar (humorous or otherwise), user tip or a suggested graphic, please feel free to put your writer’s cap on and submit your text.  Questions, comments and suggestions for future enhancements to this Guide are always welcome and appreciated.

Thanks again and 73,
Scott

N3FJP
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Chapter 1
Basic Installation
There are several methods of obtaining and installing the programs available at www.n3fjp.com. In the following sections, we will cover these methods.
· From the CD
To install any of the software from the CD, start by inserting the CD into the appropriate drive. The software CD does not self-start, so you should be familiar with accessing a CD via Windows Explorer. After opening Windows Explorer by clicking Start > All Programs > Accessories > Windows Explorer, navigate to the CD drive and select the folder of the program you wish to install. When you click on the folder you will see the files it contains.  Double-click the Setup.exe file. The Setup program will then take you through the rest of the install.  Be sure to let the program install in Setup’s default directory.
WARNING: The installation files on the CD are the same files that you can download from www.n3fjp.com. DO NOT install any version of a program from the CD over a downloaded or existing version of the same program.  Installing a new program or version in the same directory as an existing program can cause data loss.
· Via Download from the Website
You can also install AC Log via download directly from the website. Type www.n3fjp.com into your favorite browser, and on the home page, you will find a list of all the available software titles in the window located on the left side of your screen. Scroll down until you find the desired title. Clicking on the title will take you to that program’s page and the download links are at the top of each page. Click on the download link and a window will open similar to the one in Fig. 1.1.  Select Save, and place the installation file in a temporary directory on your hard drive.
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Fig. 1.1 – File Download Form
Selecting Save will cause the form below to appear:
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Fig. 1.2 – Save As Form
From this window, you should browse your PC until you find the proper place to put the download. Some people have a folder to use specifically for file downloads. Our folder happens to be “Software Download”. Once the location is selected, click Save, and the download process will begin.
· Via Download to PC not connected to the Internet
There are several ways to install AC Log on a computer not directly connected to the Internet. The simplest procedure is to download the file to a computer, and then save a copy to a CD using your CD burner software. You can then take the CD to the non-internet PC, and using the CD install directions in the “From the CD” section above, open Windows Explorer and access the CD.  Just click on the file you downloaded instead of Setup.exe.
If you don’t own a CD burner, or the PC you want to install the software on doesn’t have a CD drive, you can use a floppy drive to install the software. First, download the software to your download directory.  Start Windows Explorer, navigate to the file and right click on it. Find the menu option to Rename the file and select it. When the Rename form appears, change the last three letters from .exe to .zip, and then unzip the files. Now copy all the files from your hard drive to floppy disks (not including the .zip file itself). Most non-network versions of N3FJP software require three floppies.  Network versions require more.  Take the floppies to the destination PC and copy the files to a temporary location on the hard drive. Find the setup.exe file and double click the file. Follow the setup prompts to complete installation.
· New Installation
Once you have downloaded the .exe file using the method described above, start Windows Explorer, find the location of the file and double click on it. This will automatically begin the install process. For the most part, the installation requires only minimal input from you. The setup process begins with a Welcome screen, and clicking OK takes you to a screen that urges you to close any open programs. The next screen asks you to either click the button to use the Default directory or change the directory. Use the Default directory.

· Program Group, Keeping and Deleting Files during Installation
The next screen allows you to choose AC Log’s Program Group, and we recommend that you use the default N3FJP Software option. The install process should begin at this point.  It will only require action on your part if the program displays a screen asking about deleting or keeping older versions of files. Select the Keep option if prompted. When the install is complete you will click OK to acknowledge the process has ended. The setup program will close and return you to the last Windows screen you occupied.

· Initial Start and Registration
Now click Start > Programs > N3FJP Software and click on AC Log to start the program. A registration window will appear. Simply enter your amateur call sign and the password supplied by us upon registration in the appropriate boxes and select Continue. When you have successfully registered by inputting your call sign and password, you will see a “Thank You” form. You do not have to input your password again unless you need to reinstall the program for some reason. Please keep your password in a safe place! If you do happen to lose it, please e-mail us, and we will look it up in the database.
If you have not registered the program, you can use AC Log for a 45-day trial period. Simply leave the call sign and password fields blank and press Continue. If you decide to register during the trial period, all you have to do is input your password when you register. You will not lose any information that you have entered, and you will not have to reinstall for permanent use. The trial version is a full use version limited only by the 45 days.
· Upgrades
From time to time, upgrades are available for Amateur Contact Log. Upgrades are free to registered users.  Please always use the newest version so that you have access to all the latest and greatest features. Install the software via free download from www.n3fjp.com or purchase of a new CD and follow the upgrade instructions below.

· Upgrade Instructions
Do not remove your previous version until the new version is up and running.

Download the new version from the website and install it by following the directions in the Via Download from the Website section. Let the new version install in its own default AC Log directory. When the program starts for the first time, it will ask if you are upgrading. Just answer "yes" and follow the prompts.
· Personal Settings and Log Transfer with Upgrade
When you upgrade, the log last used in your previous version of AC Log will be copied to the new installation directory and accessed when you start the new version. If you have more than one log file, you will have to manually transfer the other files.
If you are upgrading from version 2.5 or later, you can either export your other files from the previous version in ADIF and then import it to the new version, or use Windows Explorer to copy the .log and .tot files over to the new directory.  For upgrades from 2.4 and earlier, either export your data in ADIF from the old version, or from the current version’s menu options click File > Convert Log from Previous Version.
When you upgrade, you will have to reconfigure settings for the rig interface, LoTW, voice and call data settings.  During the upgrade you will have the option to transfer your personal configuration display settings for the Main Form.
· Deleting Previous Versions
Do NOT remove the older version until the new version has been installed, the existing files moved over, and you are satisfied everything is running smoothly. You can then safely remove the older version by clicking Start > Control Panel > Add/Remove Programs and click on the older version and click Change/Remove.

Chapter 2
Getting Started with Amateur Contact Log
· Introduction
Amateur Contact Log is designed to serve as a general logging program. In addition, it keeps track of your progress towards Worked All States, Worked All Counties, Worked All Countries and many other accomplishments. The program also features a call book lookup function using data freely available from the FCC and RAC websites. (This database is called AC Log Calldata and contains U.S. and Canadian call signs.) QRZ and Buckmaster HamCall data sources are also supported, and they include many DX calls. AC Log will interface with many different radios, send CW and provide DX spotting with lists and band maps.

After using AC Log for just a few minutes, we hope that you will find the basic features very easy and intuitive. To enter a contact, just type the data in the appropriate fields and press enter. There is a command button on the default Main Form that reads “Log Contact”, but you do not need to click this button to do so. AC Log automatically saves your contacts to the log file when you press Enter. You can move from one field to the next by pressing the Tab key or press the space bar to tab for most of the fields.

We have a lot of additional information and details in the following chapters, but before you read any further, we encourage you to enter a few contacts, try some of the menu options and get the feel of the program.
· Customizing the Data Entry Fields

· Choosing and Editing Data Entry Fields
Here is where the Main Form is customized for the data entry fields, layout and the tab order. You can also determine the size of the List Box as it appears on your screen. There is a Reset to original settings command to start over.

To begin customizing AC Log, click Settings > Edit Fields Displayed, Position and Tab Order. In Fig. 2.1, you will find 37 fields that can be enabled visible, 36 of which are selectable. The Call field is always visible, but can be redefined in the tab order. From the Edit Field List form, the user can decide which data fields are displayed on the Main Form by clicking in the Visible check box beside those fields. Note: The actual size of the labels and fields cannot be changed.
· Setting Tab Order
Starting with 0 (zero) in Fig. 2.1, arrange the fields in the proper numerical sequence by placing a number in each Tab box so that the cursor moves through the visible fields according to your preference.
· Arranging the Fields
To arrange your fields on the Main Form, select the Click here to enable dragging check box on the Edit Field List form. Then, after closing the Edit Field List form, click and drag the individual controls to arrange them on the main form as you like. After arranging the fields, go back to the Edit Field List form and deselect the Click here to enable dragging check box.
· Customized Field Placement
Here are some hints on arranging the data fields on the Main Form. After enabling the click and drag feature, you may drag any data field. Hold the left mouse button to drag to an empty space on the form. This can be a bit tricky. It is best to position your mouse at the edge of the object you are dragging, in the direction you are dragging it. You can’t drop a box over another visible box.  All of the hidden controls will appear underneath the Name, City, Comments field, so temporarily hide this field to see the new fields and give yourself working room.
If you plan to make most or all of the controls visible, it is best to make a few visible at a time, drag them into position and then come back and do another set. To fine tune the data entry field location, right click on the label and use the arrow keys that appear to adjust the X/Y position.

Finally, if you have DX Spotting enabled, you will have to disable it to reach the Edit Field List form. DX Spotting resizes the Main Form to place a small DX window on the Main Form, which can cause a problem when you are attempting to click and drag your data entry fields into position.
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Fig. 2.1 – Edit Field List Form
· Tab and List Behavior
· List Matches for these Fields with Tab
Clicking Settings > List Matches for these Fields with Tab brings up the form seen in Fig. 2.2 below. This function causes AC Log to update the fields as you Tab through them, based on your criteria. There are 17 fields that you can select from. IMPORTANT NOTE: As your log grows, some items that will have many matches such as country may cause a slowdown as AC Log populates the List Box.
Once you select the fields for which you would like to see matches listed, when entering information in that field and tabbing to the next field, AC Log will search the log for any matches. For example, let’s say that you have Call selected. When entering the call sign of the contact, 8P6EX and tabbing to the next field, AC Log will search for any matches and display them in the List Box.  With the Call search, information from the previous contact(s) will also display in the appropriate data entry fields.  The current list will continue to display until the next search criteria is met. You find one match based on the call sign in the example shown in Fig. 2.3.
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Fig. 2.2 – Tab List Settings Form
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Fig. 2.3 – Ex. of Matches Found
· Alert Options
The second option under Settings is New Contact & QSL Alert Options.  Enabling this function allows AC Log to alert you visually to new contacts and QSL opportunities. You have four options:

1. Alert if New
2. Alert if New on Current Band
3. Alert if New on Current Mode
4. Turn Alert Function Off

When any of the first three options are selected, AC Log will let you know if the contact is either new, or if a QSL is needed based on such items as Call, Grid, Country, State, County, etc. In each field that qualifies, either a red box with the word New or a blue box that says Need QSL will appear, alerting as you tab through the fields.
If you select the Alert if New option, then it will alert New if there are no other matches in the log. By selecting Alert if New on Current Band or Current Mode, it will alert you to new contacts or QSL info based on the band or mode. The last option disables the Alert Function. Using the alert options is an excellent way to determine if you need that weak signal DX station’s Country or the booming 6m contact’s grid square or state.

· Editing and Deleting Records
There are several ways to edit a record, but first you must find the record you want to edit. By using one of the Search methods, find the record.  Once the record is visible in the List Box on the Main Form, simply click on it and choose the Edit command button that appears in the List Box. After selecting the Edit command button, Fig. 2.4 shows the Edit Contact form that appears.
After you have edited the record press Done. AC Log saves the new data and returns to the Main Form. AC Log also provides a shortcut to edit a record. Once you have the desired record in view, simply right click on it, and the Edit Contact form will appear.
Deleting a record is easy.  Simply display the record and click on it from the List Box. Select the Delete command button and answer Yes to the “Are you sure?” question. Be sure you really want to delete the record because unless you have it backed up, it’s gone.
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Fig. 2.4 – Edit Contact Form
· A Look at the User Interface - Highlights
The Main Form is where you will spend the majority of your time. On the Main Form you will find the List Box where your contact information is displayed. By default the List Box displays the last 50 contact records entered and separates the records with gridlines. The gridlines can be turned off by clicking Settings > Appearance > Gridlines. Fig. 2.5 shows the Main Form.
To see your entire log as it grows past 50 records, click List, and you will find three sub menu options. By default, the Last 50 option is selected. You can change that to All records, which displays all of your records. You can also display a range of records by choosing the third option, From Rec # - to Rec#. Here you can enter a range of contacts to view by the record number. 

Another feature available is the ability to sort the data within a column by clicking on a column header. (The only exception is the Date column.)  For example, clicking on the Mode column header will sort your data currently displayed by SSB or CW, and clicking on the State column header gives you an alphabetical display of states worked. Clicking on the REC# column header returns the log to normal display. Clicking on the same column header a second time inverts the order.
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Fig. 2.5 – Main Form
You can edit, delete, print, and upload records by clicking on a record in the List Box and choosing the appropriate command button that appears. All of these options and more are covered in later chapters.
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Fig. 2.6 – List Box Command Buttons
· Control Key Shortcuts (within AC Log)
We have added specialized Control Key shortcuts for use within AC Log. Many people like to use keyboard shortcuts rather than using a mouse. To use these controls, please hold the Ctrl key while pressing the appropriate letter key. Some of these controls are similar to the Windows shortcuts, but they have changed their functions within AC Log. The special Control Key shortcuts are as follows (Note: The letters do not have to be capitalized.):

Ctrl A - Address Label
Ctrl B - DX Spectrum Band Map
Ctrl C - CW Setup
Ctrl D - DX Spotting Setup
Ctrl E - Edit Fields Displayed
Ctrl H – Help
Ctrl F - Frequency Privileges
Ctrl L - Watch List
Ctrl P - Phone Setup
Ctrl R - Rig Control
Ctrl T - Tab Selection Behavior
Ctrl W - CW Strings Selection

· Columns
The List Box on the Main Form of AC Log displays 33 defined columns in a default order, but you can manipulate both the order of the columns and the width of the columns. These columns can’t be deleted, but you can drag any columns that you don’t use off to the right out of view.
If you click on the header name at the top of a column, you can drag it to wherever you want it to go. As you drag the column, you should notice a blue line moving either ahead of or behind the column. Position the column you are dragging so that the blue line appears underneath and release the mouse button.
For example, if you want the On column to go between the Date and the Band columns, drag your On column along until the blue line appears between Date and Band and then release. The On column will now be positioned between the Date and Band columns. (See Fig. 2.7 and 2.8 below for an example of this action.)
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Fig. 2.7 – Example of Column Movement #1
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Fig. 2.8 – Example of Column Movement #2
You can also adjust the width of a column, making it wider or narrower. Place the cursor over the line on either side of the column header that separates the column labels from each other. The cursor should change to something resembling cross hairs. Click and drag the line in one direction or the other until the desired width is achieved. Be careful not to make the column too small. It will effectively “disappear”, and the only way to find the column you are missing is to pull the edge of each visible column until you find it.

· Saving Column Widths and Order
Once you have arranged the List Box to your satisfaction, click Settings > Save Current Column Widths and Order to save your settings. If you do not save your modifications, AC Log will revert to default column widths and order the next time you start the program. You cannot delete any columns, but you can drag the unused columns all the way to the right so they are out of your range of view.
· Fields and Field Labels
AC Log supports 32 different data entry fields.  You can choose which fields will be displayed and place them on AC Log's Main Form by clicking Settings > Edit Fields Displayed, Position and Tab Order (see Customizing the Data Entry Fields at the beginning of this chapter for details). Labels on the “Other” fields can be re-named by clicking Settings > UTC, QTH, Date Options.  You cannot change the names of any other labels, and the widths of labels cannot be changed.
· Menu Options
On the Main Form, AC Log has 12 main menu options, and many of these have sub menus. To access each menu, simply click the option, or if you prefer to use Windows shortcuts, press the Alt key on the keyboard, and then press the underlined letter of the word in the menu on your keyboard. For example, pressing Alt and then F (Alt-F) will open the File menu. Once the main menu option is open, simply type the letter that is underlined in the sub menu item, and that item will open.
Chapter 3
AC Log File Menu Options
· Introduction
AC Log creates three files when you run the program for the first time:

1) Hamlog.log

2) Hamlog.bak

3) Hamlog.tot

Hamlog.log is the working log where your contacts are stored as they are entered. This file is automatically appended after each entry, thereby eliminating the need to remember to save the file on a periodic basis. Just key in the data and press enter, and the contact is safely tucked away.
· Create Back Up
AC Log automatically creates a backup file (.bak) for each log file created. As you add contacts to your log, each entry is immediately appended to the .log file. When you close AC Log, the program updates your .bak file for the log you were using when you closed the program.

If you want to create an additional backup file in another location, click File > Create Backup. The form in Fig. 3.1 appears. By clicking Yes, AC Log opens a Windows Save Window with the default log name.  You have the option to save your log in the working directory or in another place of your choosing. The Create Backup generates two files, a .log file and a .tot file.
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Fig. 3.1 – Create Back Up Form
User Tip: A 1700 entry log generated a 985k .log file and a 1k .tot file. Saving to a floppy may not be an option for larger files. If you save the log on a regular basis and use the same name and file location, AC Log will automatically overwrite the old log.   If you want to save progressive logs, just add an identifier to the file name in the Windows Save window, such as Hamlog100904, where 100904 equals the date that the file was saved.
Writing to CD’s usually requires CD burning software.  If you want to save your backup file to a CD, use your CD burning software to copy the appropriate files from your hard drive to your CD.

· New/Open & Multiple Log File Use
You may find it necessary to have multiple logs. You may have a CW log and a SSB log, or a 10 meter log and a 6 meter log. If so, click File > New. The form in Fig. 3.2 will appear.
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Fig. 3.2 – Create a new file Form
By clicking Yes, you will then be prompted for the file name of the log you are creating, and AC Log will save the current log, KA3SEQ.log in this case, for future use. Your new log will appear with a blank screen, and the counter will be set to zero. AC Log will automatically create and associate the necessary .bak and .tot files for each new log created.  You can create as many new logs as necessary. We recommend storing each of these new files in AC Log’s working directory (this is the default).

Click File > Open to open another log file. AC Log opens the working directory and displays all of the .log and .bak files that you have created. Select the appropriate file and click Open. AC Log will load and display the file you have selected. When you close and reopen AC Log, it will always display the last log file that you had opened.
· Convert Log from Previous Version
AC Log 2.5 increased the width of the mode field and added QSL Confirmed Fields. To open logs created in any version before 2.5, this function must be run first.
· Save As
This feature performs the same function as most Windows programs. When selecting File > Save As, you can create a second, identical log but with a different name. You can also move this newly created file to another location by choosing a new path.
· Print Log
AC Log offers the ability to print logs, address labels and QSL Strips. By printing addresses and QSL Strips on labels, the volume QSLer can save time sending or answering QSLs. You can generate custom reports with AC Log, and then format and print the reports using a spreadsheet application. You can print simple log data directly from AC Log without the need for additional software. From the Main Form, click File > Print Log, and the Print Options form in Fig. 3.3 will appear.

You can orient the paper in either the Portrait or Landscape. AC Log defaults to the Beginning and Ending Record Numbers based on the first and last call of your log. This can be changed to any number to limit/include the range of your choice. You can specify the number of calls per page, the distance from both the left margin and the top of the page. You can also change the font size as well as the font style to your liking. The Zoom option allows you to Zoom based on values you enter; however, it depends on your printer’s drivers to see the intended effect.
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Fig. 3.3 – Print Options Form
· Print Address
There are several different ways to print an address label from AC Log. The first option is to select File > Print Address. This brings up the form in Fig. 3.4. From the Address Format form, you can specify the particular label setup. Options include the number of labels in the rows and columns, distance from the left margin and the top of the page and the height and width of the labels being used. Font size and Style are also options you can choose.
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Fig. 3.4 – Address Format – Amateur Contact Log Form
Are you printing only one label and using a half-empty sheet of labels? AC Log allows you to specify the individual label you want to print. Do you have twenty labels to print and a full sheet of blank labels? AC Log by default begins with Row 1 and Column 1 and will automatically increment each label, so all you do is type and press enter.
If you have the CallBook function enabled, all you have to do is enter the call sign, press tab and AC Log populates the rest of the fields. Press Print and repeat the process. Another option available is to print directly from the List Box. Once you have located the contact you wish to print, simply click to highlight it, click the Print Address button and follow the steps above.

Printing labels works well with the search feature, too. Let’s say that during the last band opening, you made ten 6 meter contacts with those guys out in EN11, the heart of Nebraska. Put EN11 in the Grid data entry field and press Search or Alt S. The List Box will display all ten of those contacts in addition to any others you’ve worked previously in EN11. Now, you can select an individual contact or multiple contacts to print. To select an individual, just click the record and click Print Address. Suppose you only want to print the first, fourth and tenth contact from the list. Click the first record and then holding the Ctrl key, use the mouse and click the fourth and then the tenth contacts on your list. Once all three are selected, click Print Address.

At the bottom of the Address Format form, the address of the first contact should already be filled in (if CallBook is enabled). Make sure your label options are set and click Print. You should now see the address of the second contact fill in, so click Print again. This time the third contact’s address should fill in so, you guessed it, click Print. Now, sit back and watch as three labels are printed at once.

Suppose there were 14 total contacts on your list, and you wanted a label for each one. In the List Box, click the first contact in the list, but this time, hold the Shift key as you go to the bottom of the list and click the last contact you wish to print. All 14 of the contacts in your list should be highlighted. Now, click the Print command button in the List Box. Make sure your label options are correctly formatted for your label sheet and click Print for each QSO. You should see each of the contacts’ info loaded, and when you reach the end, 14 labels should print out.
· Printing QSL Strips
AC Log can also print QSL strips. These can be set up to print on labels just like the addresses. Items included on the strips are Call, Date, Time On, Band, Mode, RST, Frequency and a line for your comments. To print a QSL Strip, find the contact you wish to QSL, and click to highlight. Click the Print QSL Strip command button, and the form in Fig. 3.5 appears.

Make sure all of your options are correct and click Print (and by the way, all of the options to select and print multiple entries apply here also). Out should pop a neat little label with all of the pertinent information needed to confirm a QSO. By attaching this to the QSL card, adding the address label you just printed out and putting a no-lick stamp on the card, QSLing just got a lot easier.
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Fig. 3.5 – Label Format Form
· Printing Custom Reports using AC Log and a Spreadsheet
AC Log is fine for simple printing jobs, but it does not give you the ability to print out reports in a manner that allows you to manipulate the data. However, by using AC Log in conjunction with a spreadsheet such as Microsoft Excel, you can create, format and print highly customized reports.

For example, let’s say you want all the contacts printed out for a particular State. Enter the state in the State data field and press Search or Alt S. Now click Edit > Copy Current List to Clipboard. This copies the data currently in the List Box to the Windows Clipboard. Open your spreadsheet program and click Edit > Paste or Ctrl V, and your data will appear. You can then sort, format and customize the data any way that you like and print it out.
There is another option available. By going through your list one by one, you can manually select entries by holding the Ctrl key and clicking with your mouse. Once you have your records selected, click Edit > Copy Selected Records to Clipboard. This time only those records you highlighted are copied, and you continue the process.

Printing with AC Log removes a lot of the time factors involved with QSLing, and by using AC Log in conjunction with a spreadsheet, you can retrieve any particular data then format and print it the way you want it.

· File Import/Export Introduction
AC Log currently supports two types of data formats - AC Log format and the ADIF format. Using either of these methods, moving logs from PC to PC or from a contest program to AC Log is fairly simple. Below you will find instructions for both methods as well as some tips on other issues. Note: Importing files into AC Log does not overwrite existing data; it is appended to the end of the log. However, a good practice to follow is to backup both logs before importing, and then, in the event of Murphy’s Law, your log is backed up.
· ADIF Import
· Importing Log Data from Other Programs
“How do I get my log from “X” logging program to AC Log?” As long as the logging software you are using can export its data in standard ADIF format, moving it to AC Log is simple. Please follow the steps below:
1) Determine whether or not your old program can export data in standard ADIF format.

2) If so, create the ADIF file following the instructions for your particular program.

3) Please note the name of the .adi file and its location.

4) If the file is located on the same PC as AC Log, start AC Log.

5) Click File > Import ADIF Format. Navigate to the location of the .adi file that was created from the other program and click on it.

Your log information should now appear in the List Box of AC Log.
If the old log is on another PC, simply copy the .adi file you create to a floppy or CD, bring the file over to the PC running AC Log and follow the procedure above.

· Importing Contest Log Data from N3FJP Contest Programs
Transferring your contest log data from an N3FJP contesting program is a similar procedure. Please follow the steps below:

1) Open the contest log, and be very careful NOT to start a new contest!  Now click File > Export ADIF File.

2) Note the name and the location of the file. The file extension will be .adi and the default location is the working directory of the contest log.

3) See Step 4 above and continue.

After you have imported your contest log into AC Log, you may need to sort your data by clicking File > Sort Log on Date. After you have sorted the log, which can take awhile, you can also fill in any fields that are empty by going to the Edit > Fill Fields Determined by Call. This will use your CallBook feature, if activated, to fill in any blank fields.
· ADIF Export
Exporting from AC Log is equally simple. When you click File > Export ADIF Format, you’re then presented with three options: Whole Log, Selected Records or From Rec# - To Rec#. If you choose Whole Log, your entire AC Log database will be exported in ADIF format.

You can also select specific records by choosing Selected Records. Using your mouse, begin by clicking on the first log entry you want to export. For each subsequent entry you wish to choose, hold down the Ctrl as you click, multi-selecting a group of records. Once you have selected the desired records, click File > Export ADIF Format > Selected Records. The selected records will then be exported in ADIF format.

Your third option is to choose a range of records. For example, you may only want to export entries for a particular date. Choose the first and last record entry to export, and click File > Export ADIF Format > From Rec# - To Rec#. A box pops up where you can enter the starting and ending record number. Now click Continue and export the file.
· AC Log Format
AC Log also provides a comma delimited option for importing and exporting logs between PCs and programs. As far as the User is concerned, the process is much the same as ADIF. Under File there are two selections - Import and Export File – AC Log Format. Choosing the Import option reveals options based on the version number of AC Log. Choose the version of the program you are importing the log from. Likewise, selecting Export reveals two options - Whole Log and Selected Records. These options work the same as described in the ADIF section previously. It should be noted that the AC Log format is being phased out in favor of ADIF format.
· Maintaining Log Data on Two Separate PCs
Many hams have multiple PCs that they keep their log data on for various reasons. To maintain your log data on two computers, please follow the steps below.
1) From the computer with the most recent data click File>Export - ADIF Format.

2) Save the file to a floppy and take the floppy to the computer with the older data.

3) From the "old data" computer click File>Reset Counter, and enter a value of 0.

4) Then click File>Import - ADIF Format and select the file on your floppy.
· Preparing Data for Import using MS Excel
If your other logging program does not export in standard ADIF Format, you may want to use a spreadsheet program such as MS Excel to first arrange the data in the order that you want to import it into AC Log. You can use the MS Excel conversion utility available on the FAQ page at www.n3fjp.com to download and make these changes. If you have any questions or problems, please e-mail us: snkdavis@aol.com.
· Reset Counter
You can use this feature to change the total contact counter. For example, if you are importing a log, and you don't want any current entries included, set the counter to zero before you import.  One use of this feature is when you maintain logs on two different computers.
· Sort Log on Date
You can use the Sort Log on Date option to sort the records in your log by date.  This is especially helpful when you have added records manually from paper logs, imported contest records, etc.  Clicking File > Sort Log on Date arranges your log chronologically.
Your file will be sorted by date (entries without valid dates will not be sorted). Once sorted, the file cannot be returned to the previous order. For best results, your date settings in AC Log and your operating system should be set as closely as possible. To change your operating system date format click Start > Settings > Control Panel > Regional Settings > Date. To change AC Log's date format settings click Settings > UTC, QTH, Date Options.
· Convert FCC/RAC Database
This feature is only used if you have downloaded the FCC or RAC database directly. It will convert the data to files used by AC Log. If you download files directly from the FCC, the data files will require over 150 mg of space on your hard drive, so make sure you have LOTS of free disk space if you choose this method. AC Log utilizes components of the "en.dat" file. You can delete the other FCC files to free disk space. "AC Log ready" data is available free on our website (22 mg zipped file).
· Transfer Other Field
This function is used to transfer data in the original Other data field to any of the new fields that became available in 2.0. By clicking File > Transfer Other Field, you can have AC Log move the contents of the Other field to another field. This feature can be performed on a range of entries saving time by not having to do this on an individual basis.
· Watch List
AC Log allows you to create a personal “Watch List” of stations you would like to be on the look out for.  To enable this feature, click File > Watch List, and fill in the information you would like to watch for.  When you enter a call in the call data field that matches any calls on your Watch List, AC Log will alert you with a “Watch List Match!” form.  If you are using DX spotting and a call listed in your Watch List is posted, AC Log will alert you to the call and frequency of the post.
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Fig. 3.6 – Watch List Form
Chapter 4
AC Log Edit Menu Options
· Mark Selected Records as QSL Sent or Received
Sometimes you may need to mark multiple records for which you have either sent or received QSLs. You can select multiple records to mark by holding Shift or Ctrl and selecting records with your mouse.  Once you have highlighted the records you wish to mark, click Edit > Mark Selected Records as QSL > Sent or Received.
· Fill Fields Determined by Call
Many times you may get only partial information on a contact. Just after you make contact and you’ve exchanged call signs, the band drops out, and you have to look up the person on the Internet. Or maybe you’re working a contest, and you’re just taking time to exchange call sign, state and RST, but later you’d like to know a little more about each contact.

Click Edit > Fill Fields Determined by Call. Using this function, AC Log will fill all empty fields in all the records of your log that can be determined by the call sign. These include Country, Prefix, Continent, CQ Zone and ITU Zone (zones when discrete for a country). The Band and Mode fields will also fill if they are blank, and the QSO record includes a frequency in the US ham bands. If you have the CallBook function enabled, it will also add information such as State, County, Grid Square, Ten Ten #, etc. if available from the data source that you are using. Be aware that if you are using one of the Internet options as your data source and your file is large, it will take a while to complete this function.
· Moving Data by Copy/Paste Function
· Copy Current List to Clipboard
This will copy the records currently displayed in the List Box (results of a search or entire list) to the Windows Clipboard. This is a very quick and easy way to extract any portion of your log. The contents paste perfectly into spreadsheets such as Excel. You can also paste the data into a text editor, but that will require additional formatting. It is best to start with Notepad, with the word-wrap disabled if you use a text editor.

· Copy Selected Records to Clipboard
By using the Ctrl and Shift keys and your mouse, you can multi-select records to be copied to the clipboard. First, select the desired records, then click Edit > Copy Selected Records.
· Adding/Deleting Counties
You may also edit countie.txt with a text editor. If you do, make sure your editor does not add any hidden formatting! (Notepad should be fine.)
Chapter 5
AC Log Settings and Search Menu Options
· List Matches for these Fields with Tab
AC Log allows you to search your log to find information in virtually any category. You can make the search as inclusive or exclusive as necessary to find what you need to know. There are two methods we will investigate - a search using the Tab function and the standard Search function.
· The Search Menu Option
· Search by Tab
You can search your log for matches each time you tab through a field while you are entering a contact. Depending on criteria selected by the user, AC Log will display any information matching the fields as you Tab through them.

· The Search Function
Do you QSL?  Do you chase AWARDS?  Do you want to know how many 40 meter CW contacts you’ve made, or how many confirmed 6 meter SSB contacts you’ve made with EM40? AC Log makes it easy to search your database for these and other queries.

Imagine you’re working a 6 meter band opening, and you are grid hunting. You hear a ham on 50.145 who indicates that he’s in FN11. Put FN11 in the Grid data field and click Search or Alt-S, and AC Log tells you that you have indeed worked 4 contacts in FN11. Are you trying for WAS40 and want to know how many QSL cards you’ve sent so far?  Put in 40 meters in the Band data field, SSB in the Mode data field and check the QSL Sent box.

This ability to narrowly define your search criteria comes with a catch. If you use the Rig Interface function to automatically input FREQ/BAND/MODE into AC Log, you must disable the Rig Interface before performing the search. The FREQ/BAND/MODE fields can not be deleted or typed over without disabling Rig Interface. Simply click Settings>Rig Interface and select None.  Perform your searches and remember to enable the Rig Interface function when you’re done.
User Tip: Search entries must be exact. For example, is the date format 1/1/01 or 01-01-2001?  They are different. When in doubt, find an entry that fits your search request and highlight it. Select the Edit command button and note the date format. What is entered on the Edit form is the format you need to enter to perform your search.
Clicking Settings > List Matches for these Fields with Tab brings up the Tab Settings form. This function causes AC Log to update the list for matches with the current fields as you Tab through them, based on your criteria. There are 17 fields that you can select from and you can select any or all based on your needs.  You’ll find additional information in the Becoming Familiar with Amateur Contact Log section. IMPORTANT NOTE: As your log grows, some items that will have many matches such as country may cause a delay as AC Log populates the List Box.
· New Contact & QSL Alert Options
The second option under Settings is New Contact & QSL Alert Options.  Enabling this function allows AC Log to alert you visually to new contacts and QSL opportunities. You have four options:

1. Alert if New
2. Alert if New on Current Band
3. Alert if New on Current Mode
4. Turn Alert Function Off

Please see Chapter 2, page 17 for a more in depth explanation of the Alert menu options.
· Edit Fields Displayed, Position and Tab Order
Here is where the Main Form is customized for the data entry fields, layout and the tab order. You can also determine the size of the List Box as it appears on your screen. There is a Reset to original settings command to start over.

To begin customizing AC Log, click Settings > Edit Fields Displayed, Position and Tab Order. In Fig. 2.1, you will find 37 fields that can be enabled visible, 36 of which are selectable. The Call field is always visible, but can be redefined in the tab order. From the Edit Field List form, the user can decide which data fields are displayed on the Main Form by clicking in the Visible check box beside those fields. Note: The actual size of the labels and fields cannot be changed.
· Setting Tab Order
Starting with 0 (zero) in Fig. 2.1, arrange the fields in the proper numerical sequence by placing a number in each Tab box so that the cursor moves through the visible fields according to your preference.
· Arranging the Fields
To arrange your fields on the Main Form, select the Click here to enable dragging check box on the Edit Field List form. Then, after closing the Edit Field List form, click and drag the individual controls to arrange them on the main form as you like. After arranging the fields, go back to the Edit Field List form and deselect the Click here to enable dragging check box.
· Customized Field Placement
Here are some hints on arranging the data fields on the Main Form. After enabling the click and drag feature, you may drag any data field. Hold the left mouse button to drag to an empty space on the form. This can be a bit tricky. It is best to position your mouse at the edge of the object you are dragging, in the direction you are dragging it. You can’t drop a box over another visible box.  All of the hidden controls will appear underneath the Name, City, Comments field, so temporarily hide this field to see the new fields and give yourself working room.
If you plan to make most or all of the controls visible, it is best to make a few visible at a time, drag them into position and then come back and do another set. To fine tune the data entry field location, right click on the label and use the arrow keys that appear to adjust the X/Y position.

Finally, if you have DX Spotting enabled, you will have to disable it to reach the Edit Field List form. DX Spotting resizes the Main Form to place a small DX window on the Main Form, which can cause a problem when you are attempting to click and drag your data entry fields into position.
· UTC, QTH, Date Values, Location and Renaming Other Fields
To personalize Amateur Contact Log for your QTH, click Settings > UTC, QTH, Date Options. Choosing this option allows you to define information specific to your location in Fig. 5.1 below. You can also set your QTH Country, Latitude and Longitude. Why is this important?  When you are chasing that weak signal DX station and you don’t recognize the location by the prefix, just type in the call sign and AC Log will place the country name in the Country data field and give you the exact beam heading from your QTH.
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Fig. 5.1 – Settings Form
While you are on the Settings form, you should set your time adjustment for UTC. See the clocks in Fig. 5.2 below. You can also set the format for the date as AC Log will display it. For best results, you should have the date format for AC Log and the date format for your operating system set as closely as possible. To change your AC Log date format click Settings > UTC QTH & Date options.
To set your operating system format click Start > Settings > Control Panel > Regional Settings > Date. This will help AC Log and the operating system understand each other.
AC Log allows you to choose the Date Default Value. You may choose to automatically display the Current Date or the Last Entry Date. Choosing the Last Entry Date option is helpful if you are entering contacts from paper logs or old contest logs.
You can also rename the four “Other” data entry fields on this form if you have chosen to make them visible. You can choose to display and place these renamed “Other” fields by clicking Settings > Edit Fields Displayed, Position and Tab Order from the menu options.
· Bearing and Distance Display
If you selected the Bearing, Miles and Continent label fields to be displayed, AC Log will give you the Continent, Bearing and Mileage to the DX station based on your Lat/Long as shown in Fig. 5.2 below.
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Fig. 5.2 – Main Form – Ex. of Bearing/Miles/Continent
Notice that as soon as you type in a call sign, AC Log will populate the Country field. You will notice in the bottom left hand corner, that the Bearing to New Zealand is 232 deg, Mileage is 7,499, and the Continent is OC for Oceanic. You may also notice that there are RED indicators in the Call and Country fields. These indicators show that this is both a new contact and a new country. These Alert options are discussed in Chapter 2.
· Appearance
· Changing Color of Main Form, Labels and Data Entry Fields
You can see the Color Selections form in Fig. 5.3. To change the default color scheme, choose Settings > Appearance > Color. You can select colors for text and background in the Label and Data entry fields as well as the Form Fore and Back colors. There are three display windows to preview your selections. Just in case you decide to return to the original settings, but forget what they were, there is a Restore Defaults command button.

· List Box Text Color Options for QSL Status
AC Log also gives you the ability to see visually the QSL status of individual contacts using the Color Selections form. You can choose the color of Confirmed Sent, Confirmed Rcvd and Confirmed Sent & Rcvd.
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Fig. 5.3 – Color Selections Form
· Font
You can choose the Font, Style and Size for the text in the List Box by clicking from the menu options Settings > Appearance > Font. The Font Selection Form is seen in Fig. 5.4.
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Fig. 5.4 – Font Selection Form
· Gridlines, Taskbar and Form Size
The sub menu options under Appearance for Gridlines, Taskbar and Form Size are options for displays on the Main Form.  Clicking Appearance > Gridlines will turn the gridlines in the List Box on or off.  The default is on.

Clicking Appearance > Taskbar will allow the Taskbar either be displayed as part of your AC Log form or have the AC Log form be a separate window above the Taskbar.

Clicking Appearance > Form Size will bring up the form below in Fig. 5.5, and this option enables you to change the form size of AC Log’s Main Form.  The program must be restarted for the changes to take effect.
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Fig. 5.5 – Screen Size Percentage Form
· Transmit CW and Phone
Settings > Transmit is the next option. In AC Log, you can send CW from the keyboard as well as preset strings, and you can also send audio files. When you select Transmit, you choose between CW Setup and Phone Setup. Choosing CW Setup brings up the CW String Selections form in Fig. 5.6.
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Fig. 5.6 – CW String Selections Form
· CW Setup
To send CW, you must be in CW Mode.  Click Settings > Transmit > Select Mode > CW. You will need to build or purchase a CW keying interface to use between your computer’s serial or parallel (printer) port and your transmitter. Schematics and purchase options are available on the website www.n3fjp.com. From the Keying Options box, select which line to key the transmitter.
If you are using a serial port, tell the program which comm port to use. The program will only let you leave this field if a valid comm port is selected, or if a value of 0 is entered (indicating that a comm port has not been selected). If you are using a parallel port, enter the Hex address of the port. & H378 is the default on most systems for LPT1.

Now that the interface is hooked up, and you have either identified the serial comm port or entered the LPT1 address for the parallel port, you can test the setup. Click Test to send the text in the F9 text box at the bottom of the form. The program will not generate a side tone so make sure your transceiver is set to produce one, and make sure you are on a clear frequency, because if all goes well, you will be transmitting.
Finally, enter the WPM code speed and any adjustments to the standard word spacing (0 is standard, -8 is no spacing). You can adjust your speed on the Main Form by using the up/down arrows. Click the check box if you would like to see the characters you are sending on the Main Form. To send the best code, DO NOT run any other programs, virus software, etc. while transmitting.
Enter the characters you would like to associate with each Function Key in the associated text box. From the Main Form, press the appropriate Function Key each time you wish to send the string. Wildcards are $ for Call, * for RST and # for Number (where applicable). The up/down arrows on the Main Form change speed.
· Phone Setup
From the menu options click Settings > Transmit > Select Mode > Phone. This function allows you to send .wav files. Click Settings > Transmit > Phone Setup, and you will see the form in Fig. 5.7.
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Fig. 5.7 – Phone Wave Selections Form
First, record and save your wav files. You can use the Windows recorder by clicking Start > Programs > Accessories > Entertainment > Sound Recorder.

Make sure the correct input is selected by clicking Edit > Audio Properties from Sound Recorder’s menu options. Click the microphone icon, and select the appropriate input (usually microphone or line in). Click Advanced Properties under the microphone icon and set your hardware acceleration to Full and your sample conversion rate quality to Best. Record a wav file by clicking the red button. For best recording quality with Sound Recorder, click File > Properties > Convert Now, and select CD Quality from the drop down list. Click OK, then File > Save, select a folder, give the file a name and save it.
Connect the line-out of your sound card to the audio input of your transceiver. Be VERY CAREFUL to start with your sound card’s audio output on the lowest setting. GRADUALLY increase the sound card’s output while playing a wav file until your transceiver responds appropriately. Overdriving your radio will cause a poor transmitted signal at best and the potential for permanent damage to your radio! If you connect directly to the microphone input of your radio, an interface may be required to prevent overdriving and/or damage.

When playing the wav file, you can key your transmitter manually, use VOX or an interface connected to your PC’s serial or parallel (printer) port. To use the serial port, please enter the valid comm setting (or 0 for none) and select whether you want to use the RTS or DTR line to key the radio.
Before you can use the Phone option, you must first assign the wav files to corresponding Function Keys and click Done. While keying your transmitter, press the appropriate Function Key for the wav file you wish to play.
· CW Practice Feature
AC Log also gives you the ability to practice CW. AC Log will not copy or interpret code with this function. It will only transmit CW. From the Main Form, click Settings > Transmit > CW Setup. In the bottom right corner of the CW String Selections form, there is a button called Send Code Practice. When you click this button, the form in Fig. 5.8 will appear.
There are several ways to transmit code practice using AC Log. You can use randomly generated characters by copying and pasting text or by typing into the “Text to Send” text box. Click Send to send the characters.
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Fig. 5.8 – On the Air Code Practice Form
· Rig Interface
Another one of the excellent features of N3FJP Amateur Radio software is the Rig Interface function. The Rig Interface allows you to simply tune your rig to whatever frequency you choose, and your frequency, band and mode are automatically entered into the contact record.

To set up Rig Interface, click Settings > Rig Interface, and you should see the form in Fig. 5.9. First, choose your rig from the Select Rig box. If your model is not listed, try one of the other models by that manufacturer. Consulting the manual that came with your rig should reveal information about your particular setup.

Once you’ve chosen the rig, the next step is to determine which Comm Port your PC uses. Your desktop may be Comm 1 while your laptop is Comm 2. Again, a few minutes of investigation eliminates the guesswork.

Does the interface between your PC and rig need connection power? Check with the manufacturer for your particular setup. The options available are None/RTS/DTR. Also, you can set the time interval that the software will “poll” the radio for the information. Options include 100 ms, 500 ms, 2 Sec and 10 Sec. Selecting the faster options on slower PCs may cause a delay in other functions of the software.  You may also notice a delay if you have rig interface enabled, but either disconnected from your radio or configured improperly.

Speaking of the hardware between the PC and radio, if you need any information, please visit the website http://www.n3fjp.com/ and click on the Rig Interface link. Here you will find information on some options regarding interface cables and purchasing.
In the center of the screen are two boxes where the command strings that display Frequency and Mode are entered. This information is defaulted for each rig selection, but can be modified by the user. Icom users should note that they will need to change the “56” found in each string to match their particular radio. This information is found in your radio's manual.

Under these boxes is a Test button which sends the commands entered to the rig and a display screen which shows the frequency and mode returned by the radio. Successful setup will show the frequency and the mode the rig is set on, and while tuning the rig, you should see the frequency change. Once everything is working properly click Done.
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Fig. 5.9 – Rig Interface Setup Form
· Using Rig Interface to Change Frequency
Another feature of Rig Interface is the ability to change the frequency of the rig from within the software. You can change the frequency of your rig by right clicking on a DX spot as displayed on the Band Map or Spectrum Map. This feature is now functional for all rigs listed in the Rig Option list.  To test this feature for additional rigs, at the bottom of the Rig Interface Setup form is a Change Frequency command button. Clicking this button takes you to a screen where you can format the text sent to your radio, and then enter the frequency of your choice. Pressing Send should cause the rig to change frequencies.
· Rig Interface - Additional Information and Tips
On the left hand side of the screen is a check box labeled Use Frequency. Checking this option simply enables the return of the frequency. In the Mode By box on the right-hand side of the screen are three options: Rig, Frequency, Don’t Use. Checking one of these options allows the Rig or the Frequency settings to determine the mode. At this time, the program will only return SSB or CW in the appropriate band portions. The frequency option is handy for rigs that don't respond properly to the mode string. Don't Use turns the mode return off in case you want to operate a digital mode.
At the very bottom of the Rig Interface Setup form is a display screen that shows the unprocessed data being returned from the radio. Pressing the button above the display copies this data to the Windows Clipboard, and you can paste the data into an e-mail. Sending that information to us may help in setting up a configuration for the rig.
Once you have configured your settings, clicking Done closes the Rig Interface Setup form and “saves” the settings; however, if you choose None at any time, all settings are returned to default, requiring you to reenter all information the next time you use the Rig Interface function. Make sure to write down your working settings for future reference.
User Tip (SO2R):  You may have multiple rigs that you would like to use with the software. Ed, KG4QMI, bought a DPDT switch and a 6’ double-ended 1/8” mini plug cable to work around this issue. First, he set his two Icom rigs to the same string settings and cut the 6’ cable in two and wired them to the DPDT switch. He then wired the interface cable to the switch. Now, no matter which rig he is on, a flip of the switch activates Rig Interface on the rig being used.
· DX Spotting
Chasing DX is the favorite pastime of many ham radio operators. The DX Spotting function in AC Log allows you to connect to a Packet cluster either by RF or via the Internet. Once connected, you can monitor DX Spots via a small window that opens at the bottom of the Main Form or by going straight to the DX Spotting Setup form. You can also send spots to the DX Cluster. The DX Spotting Form displays on start up when DX Spotting is enabled.
· The TNC or Terminal Node Controller
To use a Packet TNC, you will have to check your modem documentation for the proper serial port settings. Most PC comm ports default to 9600-baud rate, 8 data bits, 1 stop bit, and None for parity. This is not the same speed that the TNC talks to the radio. Most local clusters operate at 1200 baud. Other options that may come into play are Connection Power and Handshaking. Once you’re configured, click the Open Port button, and then turn on the TNC.  You should see some sort of boot-up message from the TNC. If not, experiment with your settings. Once you can see the boot-up message, try to connect. Use either Crtl C or Esc to send the Hex character to put your TNC in command mode. You do not have to press enter to send the Hex character. Otherwise, just type and press enter to send. If you seem to connect, (you see the TNC working, but still see no information is displayed) check to ensure the TNC is in Converse mode. You may have to experiment with your particular model TNC.

A neat feature with the Packet option is that you don't actually have to connect to another Packet station.  Just click the DX Only check box so that only those packets identified as DX will be displayed. As long as DX posts are being transmitted, the software will check recent posts to eliminate duplicate posts. Even if you are connected, it’s a good idea to check this box to eliminate miscellaneous comments, etc. When you have configured your DX spotting options, click Open Port to initiate the communication, and then click Done to return to the Main Form. If the list is being displayed, you can click on it to return to this form. Double click to display the Spectrum Band Map. To return the Main Form to the original display, select None from the spotting options. This code was developed and tested with a Kantronics KPC3+ TNC.
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Fig. 5.10 – TNC or Terminal Node Controller
· Telnet via the Internet
If you have an Internet connection, dial up or high speed, the Telnet option is very easy to implement. Just connect to the Internet via your ISP, select Telnet from the Select Option box, and click Open Port. Type your call sign when prompted and press Enter.
Once connected, you can configure your DX spotting options. Even though this is via the Internet, most of the commands are the same as those on your local RF cluster. By default you get spots on all bands, all announcements and WWV reports. You can customize your profile to include the information that is important to you. Once you are satisfied, click Done. This will open up a small window at the bottom of the Main Form, allowing you to monitor spots while logging.

If the DX Spotting list is being displayed on the Main Form, you can click on it to quickly return to the DX Spotting Setup form. Double clicking the small window allows you to display the Spectrum Band Map. To return the Main Form to the original display, select None from the DX Spotting Setup form.
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Fig. 5.11 – Telnet Option
· AGW Packet Engine
AC Log will also interface with the AGW Packet Engine. The AGW Packet engine will interface with your existing sound card or TNC including Baypac to send and receive Packet. To use the AGW Packet Engine, download the freely available software from http://www.elcom.gr/sv2agw/inst.htm. The file to download is AGWPE.zip. Instructions for use are on the website. Run the Packet Engine software and configure it as described on their website for your sound card or TNC. Once AGW is configured, you should see two icons in the Windows Tray beside the clock. From AC Log, click Settings > DX Spotting > Configure and select AGW Packet Engine. Click Open from the DX Spotting Setup form. You will be asked to enter your call sign, and then press OK. At this point, you should see the following message, **Successfully connected to AGW Packet Engine **. Now you are ready to connect to your local DX Cluster.
In AC Log, to send a connect request using the AGW Packet Engine, type in the format  :C N3FJP or to disconnect :D  in the text box at the bottom of the screen. Once you have configured your DX spotting options, you can leave the DX Spotting Setup form or click Done to return to the Main Form. Your spots will be displayed at the bottom of the Main Form. If the list is being displayed on the Main Form, you can click on it to quickly return to the DX Spotting Setup form. Double click to display the Spectrum Band Map. To return the Main Form to the original display, select None from the spotting options.

This code was developed and tested with a Kantronics KPC3+ TNC and has also been used with an MFJ 1274 TNC
User Tip: Although setup is not covered in this manual, AGW also works with the soundcard on your PC, eliminating the need for a TNC. Ralph Milnes, K2RLM, has an excellent website on AGW/Soundcard setup at: http://www.patmedia.net/ralphmilnes/soundcardpacket/. The November 2003 QST also has a soundcard tutorial.
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Fig. 5.12 – AGW Packet Engine Option
· HF Spectrum Map
The HF Spectrum Map shows all of the bands from 160m – 2m. Click Settings > DX Spotting > View Spectrum Map or double click in the DX Spotting form to view. This form shows the prefixes of the DX spots heard via your connection. Prefixes are placed in their approximate position on the band, and if you hold the cursor over the spot, the full call sign appears along with the frequency and time of the spot. If you have Rig Control Interface enabled, right clicking on the spot will change the frequency on the rig to the frequency of the spot.
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Fig. 5.13 – HF Spectrum Map Form
· Spot DX on Entry (DX only)
Along with monitoring the DX Cluster to see those elusive DX contacts, AC Log lets you send spots to the Cluster automatically. Click Settings>DX Spotting and choose Spot DX on Entry (DX only). AC Log will then send your contact information to the cluster for each DX spot you log. Contacts in your country are not spotted automatically.
To send a spot for contacts within your country, first be sure you have finished logging the call, go to the DX Spotting Setup form and click the Spot Last button in the bottom right hand corner. AC Log will populate the line with the last call you logged and format it correctly. You can add comments (30 character limit) or press Enter.
· Audio DX Alert
This option gives an audible alert for all DX spots. Click Settings > DX Spotting > Audio DX Alert, and you will hear N3FJP’s XYL, Kimberly, KA3SEQ. Each time a new spot arrives, AC Log will let you know.
· Audio Alert of Needed Spots (unworked or unconfirmed)
AC Log gives you the option to have an audible alert of needed spots. AC Log informs you if the spot is needed based on your New Contact and QSL Alert option settings.  Just click Settings > DX Spotting > Audio Alert of Needed Spots to set up this feature.
· “A Tutorial for the Uninitiated” by:  Ed Leicester, KG4QMI

What follows is a non-expert look at the world of Packet.  If you are already familiar with using Packet, skip ahead to the Configuration information.  Whether you use Packet to get DX spots in pursuit of chasing the elusive and exotic DX contacts, or you like Packet DX itself, traveling from node to node when conditions are good, or maybe you like "talking to" other stations and messaging other stations on the cluster; whatever the case, Packet is just another way for the amateur enthusiast to practice his/her love of the hobby.  Packet also has a serious side, providing reliable, digital communications during ARES activations in times of emergencies.

Depending on the distance of your QTH to the local DX Cluster, the basic Packet station can be as simple as a 2-meter transceiver, a terminal node controller (aka TNC) and a PC.  The PC does not have to be elaborate.  My station uses an old 133 mhz IBM ThinkPad w/32meg of ram, and runs Win95. Run that up to a 1/4 groundplane at 25', and you're in business. You don't need expensive software either. Terminal programs like Hyperterm, which comes with Windows OS or ProComm by Symantec, will connect you to the world of Packet radio. Once you have the pieces of the puzzle, you have to put them together. I will not go into radio/TNC specific connection information. "Buck" Rogers, K4ABT, has a website Packet Radio.com, which provides a comprehensive list of radio to TNC connections for every imaginable combination of radios and TNCs. His site also has a wealth of other information for the Packet hobbyist.
For the purpose of this tutorial, you need to know that most older Packet networks operate at 1200bps. Imagine, if you will, that the TNC is split into two sections. The half connected to your radio operates at a baud rate of 1200bps. So from the TNC to the outside world, via your 2m rig, your data screams?!? along at 1200bps. But from the TNC to your PC, the speed jumps to 9600bps. This is typically done over a standard RS232 serial port on your PC (usually a 9-pin male connector or DB-9m) to a corresponding serial connection on the TNC (typically a 25-pin female connector or DB-25f. Choosing the right port on your PC (either port 1 or 2) and the speed to 9600, and setting other items like parity(none), databits(8) and stopbits(1), and getting a cable to go between your PC, and the TNC gets you started. Decide what program you will use and match the port/speed/parity/databits/stopbits to what your PC is set, and then fire up the TNC. If all goes well, you should see something similar to this:
MFJ Enterprises INC TNC-2
AX.25 Level 2 Version 2.0+ Fax
Release 1.2. 02/17/89 - 32K RAM
Checksum 81C
CMD:

If you see something similar to this when you turn on the TNC, congratulations! If not, re-check your connections and software settings. One thing to be sure of, make sure the cable from your PC to the TNC is a straight-thru cable and not a null-modem cable.  If you see the TNC banner but you don't see anything you type, type in "ECHO ON" without the quotes. Once you can talk to the TNC, there are some simple commands to enter like name, callsign, location, etc. Check your TNC's manual for the correct syntax.

Now, the next step is to make the TNC and radio talk. Some radios have a jack designed for TNC connection and some even have built in TNCs, but many older rigs have neither. For older rigs you can pull off the mike and use that connector. Typically, you only need 4 wires: the PTT pair, AF input into the radio, and RF output. If the rig does not send RF through the mike jack, you can pick it up from the external speaker. You then feed these into the TNC, and you're done. I highly recommend W4ABT's website as the place to start looking for the proper pinouts for your radio/TNC combo.
So, you have made all the connections. Your PC can talk to the TNC, and the lights on the TNC flicker when it "hears" traffic. You're ready to go. But what frequency does the local DX Cluster operate on? If you are in northeastern NC, the WA4VTX cluster is on 145.710. If you are located elsewhere in NC, you can check out The Triangle East Amateur Radio Association. Here you will find another excellent resource for Packet, including operating frequencies for other clusters as well as good information on Packet. You can also contact your local club for information.
Now that you've found the right frequency, if you wait for a few minutes, you should see a station ID sent by the local node/cluster. This will allow you to know what is available on your frequency. If you're on the WA4VTX cluster, from the CMD: prompt, type "Connect wa4vtx", and hit return to log in. You can abbreviate the Connect by just entering "C". After successfully logging on, you will no longer see, or need the CMD: prompt. Commands are entered on blank lines. As you get familiar with the command structure, you will find that there are many commands that can be shortened. When you log on, others who may be connected will see a msg indicating that you are now connected. For you to see who else may be logged on, type in "show/users or sh/u" and press enter. You will see a list of all stations who are currently connected.

If you are unfamiliar with the commands that are available, type either "H or ?" and enter to see the available commands. You can see a list of the basic commands by going to the Packet Cluster Commands page on my website. Here you will find the basic commands. To see additional commands type "help show" to see what else is there, like show/dx, /bulletins, /wwv, /time, /files, /prefix and many others. Typing "help" and any command will give you the available sub-commands. One of the first things you will need to do is give the cluster some basic info, like name, location, and QTH. You probably will be prompted for this info automatically, but if not or if you need to make changes later, then you can use the set/ command. You will notice that each command is followed by the "/", as in set/, you then enter the qualifier to finish the command. Entering show/dx will show you the last five DX spots. Show/prefix "g", will show all of the prefixes under the letter G, such as GB, GD, GT, GN, GW, etc. It will give you the country name, CQ and ITU zones. Then, by entering "show/heading GW", you will get the beam heading from your QTH plus the distance based on the Lat/Long you entered for your location. Didn't set your Lat/Long/ "Set/Location 36 10 n 76 28 w" will put that in your profile.
For many people, the primary function for the cluster is to get and place DX spots on the network. There are many options involved, and you can even turn off the spot feature for yourself if you don't want to see them. To send a spot to the Cluster, use the following command/format: “DX Frequency Station Spotted Remarks” or DX 50125 KG4QMI 599+20 in FM16”. That should do it, but there are other things to do on the Cluster. Packet was the "ham’s" early internet. You can send and receive msgs from other hams. They do not have to be connected at the time to get their msg. When they log in later, they will receive a msg stating that they have mail waiting. To send a msg just type "send" and press [enter]. The system will prompt you for the callsign of the recipient[enter], then ask for the subject[enter], and finally prompt you to type in your msg. When finished, press [enter] to get on a blank line then type "/exit or ctrl/z" to send the msg. "ctrl/y" will cancel your msg. It is important to finish correctly, [enter] by itself does not send the msg. Msgs sent in general can be seen and read by anyone, but using the "/private" qualifier makes it private to the recipient.

The READ command allows you read messages on the cluster. READ by itself reads the oldest message addressed to you. READ and a msg# (ex. "Read 10") will read the message numbered 10. Once you have read a msg to you, you can delete that msg by entering "kill" and the msg number ("kill 10"). Two other commands involved with mail are "list and directory". Each of the commands will show you a list of the messages on the cluster. The "Directory" command has several qualifiers to narrow down the range of messages shown.
One of the other things you can do on the cluster is to "talk" to another connected user. By entering "talk n1dp", it opens a connection to the callsign entered and allows you to "chat" via keyboard with the other station, real-time (AOL/IM??). If someone opens a connection to you, you will see a msg from them, then you confirm by typing "talk call/sign" to respond. Either party can break the connection by entering "/exit" on a blank line. This can be done "simplex" as well. If you have someone within range of your station, you can connect to them directly by getting on a vacant simplex frequency and from the CMD: prompt, entering "Connect call/sign". Once connected you can talk or even exchanged files. Again, either station can break the connection, but this time, because you are "directly" connected, you must first return to the CMD: prompt. To get back to the CMD: prompt, most terminal programs recognize [crtl-c]. By holding down the CTRL key and pressing the "C" key, you will return to the CMD: prompt. Then, typing disconnect, you will break the connection.
I hope this information proves to be useful to you. My thanks go to Dave, N1DP and especially Herman, NO4Y, my Packet "elmers", for their patience in allowing me to pester them as I've tried to learn Packet myself.
· Voice Navigation
We have received several requests to provide support for visually impaired hams, and we’re beginning by providing voice location on the Main Form. After you copy the necessary wav files, as each data entry field receives the focus, an audio wav file of Kimberly, KA3SEQ, will identify the field. There are specific setup directions on the Voice Navigation Settings form, which appears in Fig. 5.14.
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Fig. 5.14 – Voice Navigation Settings Form
· Saving Current Column Widths and Order
The List Box on the Main Form of AC Log comes with 33 defined columns in a default order, but you can manipulate both the order of the columns and the width of the columns.  If you click on the header name at the top of a column, you can drag it to wherever you want it to go.  When you are finished arranging your columns and adjusting the order, please click Settings > Save Current Column Widths and Order to save your preferences.  Please see Chapter 2 for more details.
· Fill Data on Call Tab
This feature enables AC Log to fill all relevant fields such as Date and Time as soon as you tab from the Call field. The form in Fig. 5.15 will appear. You can enable this function by clicking Settings > Fill Data on Call Tab; however, the Search function is easier to use with this feature disabled because the Search only returns data where ALL fields either match or don’t contain data.
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Fig. 5.15 – Fill on Tab From Call Enabled Form
· Clear
AC Log’s Clear menu option does what the name says.  It clears the data entry fields and resets the List Box to display your current records.
Chapter 6
CallBook and List Menu Options
· Preferences
Amateur Contact Log has a call book lookup feature that enables you to select from several data source options to have call sign information fill for your contact. Click CallBook and select the source you wish to use from the available options. When you tab from the Call field, the name and address will display in the Name, City, Comments field if the call is found. AC Log Version 2.6 forward supports the following:
AC Log Ready Calldata (freely available)
QRZ CD (requires subscription)
QRZ Online Database (requires subscription)
HamCall Buckmaster CD (requires subscription)
HamCall Internet Lookup (requires subscription)
* Download and convert the FCC and RAC databases manually to create the AC Log Ready Calldata
· AC Log Call Data
To use the AC Log call book function, you must install the data files. This data is a free download from our website and is updated every 6 months. There are three options for obtaining the data as seen on the form in Fig. 6.1:

1. Download and unzip the data file (calldata.zip) from our website - http://www.n3fjp.com.
Once you have the call data zip file downloaded, unzip it. Then click CallBook > ACLog Calldata. Enter the path to where you unzipped the data.  Check the box to enable the Call book lookup feature, and click Done.
To test, simply enter a valid US or Canadian call sign and tab to the next field. You should see some of your fields populated with data. Name, State and mailing address in the Name, City, Comments field should be filled in and displayed as long as you have made them visible (see Chapter 3 for details).
2. Purchase the AC Log Call data on CD. This database contains U.S. and Canadian call signs.  It does not contain county or grid square information.

3. You can also download the data directly from the FCC, http://www.fcc.gov/fcc-bin/wtbdatadump.pl#amat, (updated weekly), unzip the file and run the conversion utility from the AC Log File menu (see Chapter 3 for details). Be careful, this file is very large.
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Fig. 6.1 – AC Log Calldata Form
· HamCall Buckmaster Database CD
The second option is the HamCall Buckmaster Database CD. Once you’ve installed the Buckmaster software on your PC, insert the HamCall CD into the appropriate drive on your computer, and then open AC Log. Click CallBook > Hamcall Buckmaster Database CD. A form will appear asking you to enter the letter of the drive holding the CD. Enter the appropriate letter and click OK.  Don’t enter a colon or any other character.
Once you click OK, AC Log will use the CD to find the information for your contact. If you have room on your hard drive, HamCall gives you the option of installing the entire database on your hard drive, which eliminates the necessity of keeping the CD in the drive at all times and speeds up the lookup function. If you choose this option, you can enter the designation for your hard drive such as “C” (without quotes).

· HamCall Internet Lookup
Buckmaster also provides an Internet lookup service.  If you have a fast, reliable connection to the Internet, then this may be the option for you. Use of the Internet Lookup ensures that you will always have current, updated information for your log. From the menu options click Callbook > HamCall Internet Lookup. The screen in Fig. 6.2 will appear.
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Fig. 6.2 – HamCall Internet Lookup Form
Enter your HamCall user name and your HamCall password, and then click the checkbox Enable HamCall Internet Lookup and click Done. Now enter the call sign of your contact, tab, and AC Log accesses the HamCall database via the Internet and fills the appropriate fields.

· QRZ Call Database CD
The next option is the QRZ Call Database CD. Once you’ve installed the QRZ software on your PC, insert the QRZ CD into the appropriate drive on the PC, and then open AC Log.  Click CallBook > QRZ Call Database CD. Once you click OK, AC Log will use the CD to find the information for your contact. If you have room on your hard drive, QRZ also gives you the option of installing the entire database, which eliminates the necessity of keeping the CD in the drive at all times. The folder on your hard drive containing the data must be c:\CALLBK.
· QRZ Database Internet Lookup
QRZ.com also provides the premium Internet lookup service http://online.qrz.com/. If you have a fast, reliable connection to the Internet, then this may be the option for you. Use of the Internet Lookup ensures that you will always have current, updated information for your contact records. Click CallBook > QRZ Internet Lookup. The form in Fig. 6.3 will appear.
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Fig. 6.3 – QRZ Internet Lookup Form
Enter your QRZ user name, your QRZ password, and click the checkbox Enable QRZ Internet Lookup and click Done. Now enter the call sign of your contact, tab, and AC Log accesses the QRZ database via the Internet and fills the appropriate fields.

· AC Log List Menu Option
On the Main Form you will find the List Box where your contact information is displayed and modifications to your data can be made. By default the List Box displays the Last 50 contact records entered and separates the info with gridlines.
To see your entire log as it grows past 50 records, click List, and you will find three sub menu options. By default, the Last 50 option is selected. You can change that to All records to view your entire log. You can also display a range of records by choosing the third option, From Rec # - to Rec#. Here you can enter a range of contacts to view by the record number.
Chapter 7
Awards Menu Options
· States, Counties, Countries, Other

Amateur Contact Log tracks your contacts in many different categories such as States, Countries, Grids, and Zones. You can narrow your search by band, mode, power, QSL received and limit by record number.  Leaving all the fields empty, AC Log will search and return results for the entire log.  After entering any limiting criteria, click Calculate to run the Awards function.
In each category, you will see a column showing what you have worked, and what is still remaining. Once you have finished your search, left-click in the desired column, and AC Log automatically copies the list to the Windows Clipboard, allowing you to paste the information into another application for printing or additional analysis.

· Awards
Awards are divided into two groups as listed below. All search options are available for both.
· Group 1: States, Counties, Countries, Other
· Group 2: ITU Zone, Lighthouse, Prefix, Ten Ten, CQ Zn, Continent, Other 2, IOTA, Grid, Grid (6), IARU Zn, Other 3, Other 4
Chapter 8
LoTW
· What is Logbook of the World?
Logbook of the World (LoTW) is the ARRL’s electronic contact verification system designed to simplify and reduce the costs of participating in many Amateur Radio awards programs. In order to use LoTW, please follow the steps below:

(1) Download the LoTW software (TQSL) from www.arrl.org.
(2) Submit a request for a digital certificate from the ARRL.
(3) After receiving the certificate, use it to "sign" either ADIF or Cabrillo files.

(4) Submit those signed files to LoTW via email or website upload.

(5) Receive a confirmation from LoTW acknowledging receipt of the log data.
Those who have submitted contest logs via e-mail will find this process to be nearly the same except for the added step of signing the log. Once you are registered, and your log has been uploaded into LoTW, you will be able to visit the LoTW website to see your data and any QSOs that have been matched with logs from other participating stations. For more information on LoTW, please visit: http://www.arrl.org/lotw.
· Amateur Contact Log and LoTW
Once you are a registered with ARRL’s LoTW, AC Log will make uploading your log and checking your confirmed QSOs a lot easier. With AC Log, it is as simple as a click of a button to send your files to LoTW or check to see how many new QSOs have been confirmed. AC Log also allows the user to specify qso_owncall for QSL queries.
From the Main Form, select LoTW and you will see the form in Fig. 8.1. Before you can upload your log the first time, there are some basic setup steps you must follow. First, you must have completed the 5 steps previously mentioned. You also need to verify that the TQSL software you installed is version 1.10 or later. Now, let’s begin!

1) Enter your callsign in the User Name field.

2) Enter your LoTW assigned password in the Login Password field.

3) Enter a name in the Station Location field.
4) In the Path to Trusted QSL Software verify that the path is entered correctly to your TQSL software.
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Fig. 8.1 – Logbook of the World Manager Form
· Sign and Upload
You have three upload options. The first is to upload your entire log. By clicking Entire Log, you will send your entire log - probably only necessary once. This will bring up the following form in Fig. 8.2. Each time you upload a file to LoTW, this form will appear. It gives you the option of narrowing your range to upload by dates. You can also leave both fields blank, and all the records selected in AC Log will be sent to LoTW.
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Fig. 8.2 – QSO Date Range Form
Once you press OK then you will see the form in Fig. 8.3.
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Fig. 8.3 – Enter Password Form
You will be asked to enter your password to activate your private, certified key. This password is not the one sent to you from LoTW.  It is the one you specified in your application. Then a form will appear asking you if you are ready to upload the signed file. Clicking the Yes command brings up the form in Fig. 8.4 where you can tell AC Log to verify and mark the records as sent.
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Fig. 8.4 – Upload Successful Form
Clicking the Yes command will finish the process, and after a few seconds, the form in Fig. 8.5 should appear showing the list of calls that were successfully sent and accepted by LoTW. In the Records Downloaded window, you will see pertinent information about the calls uploaded. You can resize the columns to be able to view all data in each field; however, you cannot alter any of the data from this form.
User Tip: Occasionally, the LoTW website traffic is heavy, and even though your upload was successful, the records may not be immediately available for download.  If no records are returned, wait a while and then try clicking Download Confirmed Since and enter a date and time prior to your most recent upload.  Records won’t be marked in AC Log as successfully uploaded until they have been downloaded from the LoTW website.
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Fig. 8.5 – Ex. of Records Downloaded from LoTW
You can also monitor the progress of both upload and download at the top of the form. Beside the word Status messages will appear that will take you step by step through the process. You will also notice information appear in the text box in the upper right corner. Both methods are designed to give you information regarding the status of your task.

· All Contacts not Uploaded
After your initial upload, you can periodically upload new contacts. You do not have to upload contacts on an individual basis. Let’s say you have a good day working 20 meter DX, and you make 12 contacts. Once you are finished, you can select: All Contacts not Uploaded, and AC Log will automatically search the database and will upload only those contacts not previously sent to LoTW. The upload process is the same as before.

· Upload Selected Contacts in the List Box
In Fig. 8.6 you will see a third method of uploading your contacts to LoTW. From the Main Form in the List Box, you can highlight records you wish to send by holding the Ctrl key and selecting the contacts with your mouse.  Then click the LoTW Upload command button in the List Box. This returns you to the form in Fig. 8.1, and this time you choose Selected Contacts from Main Form and again, the process repeats itself.
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Fig. 8.6 - Selecting Individual Contacts in the List Box
· Download
Now that you have successfully uploaded your entire logbook to LoTW, it’s time to see if you actually have any confirmed QSOs. Click LoTW from the menu options. Since this is your maiden voyage, you would choose All Data. This causes LoTW to download the entire database it has for you, and then AC Log compares that data with your log records. If there are any discrepancies, AC Log will ask you if you want to add those entries.
· All Confirmed
If you are satisfied that your log is up to date, select All Confirmed, and AC Log will request all of your confirmed QSOs. After a few moments, LoTW will send all of the contacts that have been confirmed.
On the screen that appears you will see all of the confirmed contacts that match those in the LoTW database. All pertinent information is shown, but this is a read-only screen. You can change the viewing size of the columns to see the entire field, but you cannot edit. Once you are satisfied, press Done, and you will return to the Main Form. AC Log will sort the data, and you can view the status of your download in the same manner as your upload.

· Confirmed Since (Date)
The last option available is to specify how far back you want to go. By choosing the Confirmed Since button, AC Log will give you an opportunity to specify a beginning date and defaults to the date of your last request.
Once you’ve entered the date, pressing OK causes AC Log to request confirmed QSOs based on the date entered. The Logbook of the World Manager form will appear showing the progress. Pressing Done closes the LoTW form.

· What does AC Log do with the LoTW Data?
There are four columns that AC Log updates for LoTW:
1) S (QSL Sent)
2) R (QSL Received)

3) S Conf By (QSL Sent via which source)

4) R Conf By (QSL Received via which source)

The S and R columns are automatically filled to let you know that a confirmation has been Sent and/or Received. The S Conf By and R Conf By columns tell you how the QSL was confirmed.  Contacts with an L indicate the QSL was confirmed by LoTW. Contacts confirmed with an old-fashioned QSL card are marked C by editing the contact and either entering C or manually or selecting the QSL check box.
Chapter 9
Country List, Recall and Help Menu Options
· Country – List
This option will open a window listing all countries in the database and the country's prefix.  Selecting a header will sort the fields alphanumerically. You can also delete a country by clicking on the record number or add a country from this form.
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Fig. 9.1 – Country-List Form
· Recall
This feature was added at the request of county hunters who work mobiles parked on the county line. By recalling all data from the previous entry, only the county and maybe the time need to be changed.

· Help Menu
One of the menu options is Help which includes a Help File, a Features Summary and a Frequency Privileges chart. The Help menu option will display a basic Help file for Amateur Contact Log.  The Features Summary lists the main highlights of the logging program. You may also choose the option to show the Frequency Privileges chart for U.S. amateur licenses.  By clicking on the buttons at the top for the different classes, the display will change to show the various frequencies.
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Fig. 9.2 – Frequency Privileges Form – Extra Class (U.S.)
Chapter 10
eQSL
· Getting Started
Amateur Contact Log also has the ability to upload entries to eQSL. First, you must be a registered user of eQSL. If you are unfamiliar with this service, you can visit their website http://www.eqsl.net/qslcard/Index.cfm for more information.

To send an entry to eQSL, simply highlight that record in the List Box on the Main Form. This will display a group of buttons as seen in Fig. 10.1.  Using this method, you can only send one record at a time. This limitation is at the request of eQSL.  They have asked that bulk uploads be done the “regular” way, by exporting an ADIF file from AC Log and then uploading to their website. If you’re not familiar with the ADIF format and how to use that feature in AC Log see Chapter 3, and you will find a detailed explanation of the ADIF Export and Import features.
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Fig. 10.1 – Command Buttons

Clicking on the eQSL Upload command button will take you to the eQSL Upload form. The first time you attempt an upload to eQSL, you will need to enter your eQSL Username and Password. Afterwards, simply click Upload, and off it goes. eQSL handles the rest.  eQSL confirmations are not recognized as valid by the ARRL for awards purposes.  Therefore, the QSL Sent and Received fields are not modified for eQSL confirmations.
Appendix A - FAQs about N3FJP Software
How do I download and install a program from the website?

I have a list of step by step instructions on my Installation Tips page. Please click the link for complete details.

How do I install the program on a computer that is not connected to the Internet using floppy disks?

- Download the installation file to your hard drive by clicking on the download link on my website with your web browser.

- Start Windows Explorer from the Windows Start menu.

- Navigate to the file and RIGHT CLICK on it.

- Select the option to rename the file and change the last 3 characters from .exe to .zip.

- Unzip the file.**
- Copy all the files (except the zip file) to your floppies. It should take two floppies unless it is a network version of our software. If it is a network version, it will take 7 floppies.

- Copy the contents of the floppies to a temporary directory on your destination computer.

- Double click setup.exe.
**Note:  If you have a CD burner or zip drive it is unnecessary to rename and unzip the file downloaded from the website. Just copy it from your hard drive to the CD or zip disk and take it to the destination computer.

Is there a link on your website where I can download the package all at once?
At this time, when you register the $39 package, there is not a link to download the package all at once. You can download the programs as needed from the website on their individual pages. There is no time limit, and you can download as often as you like.

Can I transfer the log data file from my "old program" to AC Log?
If your old logging program exports its data in standard ADIF format, you can import your log data files to AC Log with no problem. Please try the following:

- Export your data in ADIF Format from your old log.

- Note the location and name of the .adi file created by your old log.

- Open AC Log.

- From the Menu Options click File>Import ADIF Format.

- Navigate to the .adi file location.

- Double click on the .adi file and your log data will appear in the List Box on the Main Form of Amateur Contact Log.**
**Note:  After you import your ADIF file into AC Log, and your log data is out of order, parts are missing, etc., the log you transferred the data from was not using the standard ADIF format. You can sort your log by clicking File>Sort Log on Date. Many of the missing data fields can be filled by clicking Edit>Fill Fields Determined by Call. If you continue to have trouble, please send us an e-mail with the .adi log file attached, and we will be happy to take a look.

How do I get my log that I have kept as an MS Excel worksheet into AC Log?
I have prepared a simple Excel spreadsheet that will help you convert the data. Please visit www.n3fjp.com to download a copy of the spreadsheet.

How do I transfer my contest contacts to AC Log?
Steps for transferring your contest data to AC Log:

- From the contest log menu options click File>Export ADIF Format.

- Note the name of the .adi file and its location (default location is the working directory of the contest program).

- Open AC Log.

- Click File>Import ADIF Format.

- Navigate to the .adi file location.

- Click on the .adi file, and your contest data will appear in the List Box on the Main Form of Amateur Contact Log.

Do your programs support the ARRL's Log Book of the World?
Yes, the Log Book of the World uses either ADIF or Cabrillo format. All of our software will export in either one or both of these formats. In addition, AC Log will upload and download confirmations from LoTW and update your log file automatically.  For more information on LoTW, please visit the ARRL’s website:  http://www.arrl.org/lotw/
In addition to regular contest submission, will I be able to upload my contest contacts to the ARRL's Log Book of the World?
Yes, the Log Book of the World uses either ADIF or Cabrillo format. All of our software will export in either of these formats.

How do I maintain data on two computers?
From the computer with the most recent data click File>Export - ADIF Format. Write the file to a floppy and take the floppy to the computer with the older data. From the "old data" computer click File>Reset Counter, and enter a value of 0. Then click File>Import - ADIF Format and select the file on your floppy.

How do I export my log to a floppy?
From the menu options click File>Export - ADIF Format; navigate to the destination drive and click Save.

I have downloaded the call data from the AC Log page on your website. How do I get the Amateur Contact Log call data lookup function to work?
- Download the AC Log Ready Call Data (click here) and unzip the file.

- Open AC Log.

- From the menu options click Callbook.

- A form will appear giving instructions on the calldata.

- Click the checkbox for call book lookup at the bottom of the form.

- In the text box at the bottom, enter the directory where the call data resides (the directory where you put the unzipped file). If you put the call data in the program’s working directory the entry would be: C:\Program Files\AC Log 2.6.

- Click Done.

- After entering a valid U.S. or Canadian callsign, when you tab from the call field to the date field, the name and address will appear in the Name, City, Comments field.

I have purchased your CD with the call data on it.  How do I get Amateur Contact Log to use the call data lookup function from the CD?
- Insert the N3FJP Software CD into your CD ROM drive.

- Open AC Log.

- From the menu options click Callbook.

- A form will appear giving instructions.

- Click the checkbox to enable call book lookup at the bottom of the form.

- In the textbox at the bottom, enter the location of your CD ROM drive and the calldata directory.  For example, d:\calldata.

- Click Done.

- After entering a valid U.S. or Canadian callsign, when you tab from the call field to the date field, the name and address will appear in the Name, City, Comments field.  Accessing data from the CD is usually slower than using your hard drive.

I have signed into QRZ with my password, but the QRZ Online Callbook feature does not seem to work.
The QRZ Online Callbook option is not included with the free QRZ membership and services. This is a premium subscription service offered by QRZ to help support all their hard work and efforts for the amateur community. Please visit QRZ for more information - http://online.qrz.com/

I use the Buckmaster Hamcall CD. Is there a way I can copy the data to the hard drive and have AC Log access it for faster lookup?
Yes, after you copy your data to the hard drive, from AC Log's menu options click Callbook> Hamcall Buckmaster CD and enter the designation of your hard drive. Don't type any other characters such as a colon or backslash. Just enter the letter such as "C" (without the quotes).

I use the QRZ CD. Is there a way I can copy the data to the hard drive and have AC Log access it for faster lookup?
Yes, copy the entire folder CALLBK from the QRZ CD to your hard drive. AC Log will then find the data. The folder on your hard drive containing the data must be c:\CALLBK.

I want to have a "hard copy" of my contest log. How do I print it?
If you want a "hard copy" of your contest log, you can print the Cabrillo, ASCII or data file you created for contest submission by opening the file in a text editor such as Notepad and clicking File>Print.

I want to keep a copy of my contest file. How do I save it?
If you want to keep a copy of your log file after the contest, you need to copy it to a new directory and rename the file. After you exit the contest program and start it again, you have the option to continue an old contest or start a new one. If you choose to start a new contest, your old file will be gone. Most users export their contest contacts to AC Log for a permanent record.

I would like to backup or transfer my AC Log customized settings. Which files should I copy?
You will need the following files:

ACCtrlLc.txt

hcolm.txt

hcolmord.txt

hcolors.txt

tabord.txt

The AC Log bearing and distance doesn’t seem to work properly for stateside QSOs.
The bearing and distance works best for DX. With versions 1.8 and later, we have included the latitude and longitude of the state capitals so, when you enter the state, the calculations should reflect the bearing and distance from your QTH to the state capital. Buckmaster's Hamcall CD does include coordinates for all hams, and AC Log will use these values to calculate bearing and distance if you are using the Hamcall CD for lookup. Also, if you are recording the grid square, the bearing and distance will update based on the value you enter in the grid square field.

I've rearranged the list column heading order and changed some of the widths in AC Log. How do I make these changes permanent defaults?
Once you have your column order and widths the way you like, double click anywhere on the white listing display area (List Box). A message box will appear confirming that your column defaults have been updated. With version 2.4 and later, you can also click Settings>Save Current Column Width and Order.

How do I get AC Log to display the date format I want? The sort function is returning an order out of chronological sequence.
For best results, you should have the date format for AC Log and the date format for your operating system set as close as possible. To change your AC Log Date Format click Settings>UTC QTH & Date Options. To set your operating system format click Start>Settings> Control Panel>Regional Settings>Date. That will help AC Log and the operating system understand each other.

AC Log always inserts CW in the Mode Field even when I try to change it.
When you have the Rig Interface function enabled, the Mode Field will automatically fill depending on the portion of the band you are on with CW or SSB. To be able to input your preference, you need to disable the Rig Interface function.

When I purchase one of the software packages, am I entitled to any new Amateur Radio programs that are added to the package after my purchase?
Yes, any new Amateur Radio programs will be freely available to those that have registered our software package. We usually send an e-mail announcement with information about a new program. If you have registered the package and would like to use the new software, just send us an e-mail, and we'll forward an updated password list.

I have purchased a couple of programs from you. How can I upgrade to a software package?
We offer hams who have purchased combinations of software to be able to use the amount they have contributed so far towards the $49 N3FJP Software Package & CD or the $39 N3FJP Software Package without CD. Please e-mail us, and we will confirm your registrations so far and give you the amount you need to upgrade to the package. 

Are upgrades free to registered users?
Yes, so far all upgrades have been free to registered users. We have no plans to change the policy at this time.

I purchased the N3FJP Software Package & CD some time ago. Since then you have released new versions for a number of programs. Can I get a new CD with full use of your software for less than $49?
Yes, upgrades are free to registered users. You have already purchased the package so all you need is a new CD. You can purchase a new CD for $13 (including shipping). Please visit our Register Now! page to use the PayPal button for the CD only order.

When using your log for Field Day, do we have to purchase separate licenses for each computer/station we use?
You may use and install the Field Day Contest Log and the Field Day Network Log on multiple computers at one Field Day site with one registration. Please keep the password confidential for club use only.

Would you mind if I put a link on my website to your site http://www.n3fjp.com/?
We would very much appreciate it! Most of our customers find us by hearing about our software from other satisfied customers.

Are you going to write a program for _________?
We have LOTS of potential projects on the list as well as ideas for upgrades on the existing programs. Please e-mail us, and let us know what programs are of interest to you. Knowing the level of interest for potential projects is a big help in prioritizing our work.

Is there an e-mail users group for your software?
Yes, please visit www.n3fjp.com to learn more.
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